version 2.8.1. does NOT work on FF2 (2.0.0.14) Rated 1 out of 5 stars

Exception: ReferenceError: XPCSafeJSObjectWrapper is not defined. That prevents using this add-on on FF2 (2.0.0.14). Version 2.8.0 worked and I am getting this when tried to upgrade. Please FIX!

This review is for a previous version of the add-on (2.8.1).