Please support FF4b Rated 5 out of 5 stars

I love this add-on, helps me keep track of 4 different time zones simultaneously! But I hate the fact that it doesn't work with Firefox 4 beta. This and a few more add-ons are the only reason keeping from using the beta builds full time. :( Would be awesome if you could support it.

This review is for a previous version of the add-on (2.6.18).