Please Update Rated 3 out of 5 stars

Please Update it for Firefox 4.0b6

This review is for a previous version of the add-on (2.0). 

Force-TLS in Firefox 4

Hi TBABlackPanther. Firefox 4.0 already has most of Force-TLS built in as a feature called Strict-Transport-Security.

Version 3 of Force-TLS will work in firefox 4!