Great when it works Rated 4 out of 5 stars

This worked great with 3.6, but not 4.0b6. Any ETA for support? Thanks!

This review is for a previous version of the add-on (2.0). 

Hi dsrw,
Most of ForceTLS is already built into Firefox 4! To get the UI bits, you want to use the STS-UI add-on: https://addons.mozilla.org/en-US/firefox/addon/246797/