latest Firefox 4 beta uncompatible Rated 2 out of 5 stars

please make it compatible with firefox 4.0 beta 9 +

This review is for a previous version of the add-on (2.1.10).