Shows wrong rendered font Rated 1 out of 5 stars

This extension is worse than useless because, although it shows the correct font stack, it can actually show the wrong rendered font.

For example, I have a stack that starts with Georgia, Times, etc... This extension claims that the font actually rendered is Times, but that's simply untrue; Georgia is available and is being rendered. Although they're fairly similar fonts, I know the difference between the two -- just zoom in on a lower-case "i" or "j" and it's obvious. (I used to teach typographic design.) Anyway, just to make sure I wasn't making a mistake, I checked it against a font book. I wasn't wrong; the extension was.

I don't know what the problem is with this extension. Might it be because I'm using an older version of Mac OSX? (Snow Leopard, 10.6.8.) Hard to believe that would matter... and if there's a compatibility issue, it should just refuse to work at all. Anyway, until they correct this bug, I advise people to avoid it because it could confuse you big-time.

By the way, they do seem to have fixed the entirely different problem I reported back in 2012, in my prior 1-star review. I thought I'd give this another chance now. Oh well.

Can you give an example?

Can you put up an example on http://jsfiddle.net/? That would be incredibly useful in helping us fix it. We detect the font based on replaying the CSS' stack and then stubbing a bunch of elements to find a matching height/width (that's why fixed-width fonts won't work.)

I've been playing with a new mechanism against more modern versions of FF, but a live example of an unhappy result would really help me vet the possible new solution.

Rated 1 out of 5 stars

I'm using Mac Firefox. Until recently, Font Finder worked fine. In the newest version of Mac Firefox (15.0.1), however, Font Finder only works the first time I use it after launching Firefox. After that, the extension doesn't work. I have to quit and re-launch Firefox each time I want to use Font Finder -- which obviously makes Font Finder completely impractical to use. The highlighting (of the extension's icon, if clicked on, and the text) seems normal, but no informational box pops up at all. Nothing. It (mis)behaves the same way regardless of whether I use the Font Finder contextual menu or the toolbar icon. A shame, really; it was great when it worked.

Does the developer test this in the Mac version? Of course it's possible there's some conflict with another extension I run, since I do run a bunch. Any suggestions would be appreciated; I miss this extension.

This review is for a previous version of the add-on (1.0.1-signed). 

Yes, this is tested on Mac (10.7 and 10.8.) Your description didn't help me recreate the issue.

<br>I'm in the process of debugging this and releasing a fix.<br><br>This bug is being tracked at https://github.com/ecaron/firefox-font-fonder/issues/1. All the information that you could provide to help me reproduce this would be greatly appreciated.