Not Compatible w/ FF 23.0.1 Rated 5 out of 5 stars

I LOVE the add-on. Firefox won't install this anymore because it says it's not compatible. Even altering the install.rdf file won't fix it. As a web designer I rely on this add-on a lot because my laptop doesn't support beyond 10.6.8. With iOS scrollbars altering page layouts, this add-on was the perfect solution to allow me to design as if I had IOS scrollbars on 10.6.8. Please fix this soon!