could be compatible with firefox 3.5 ? Rated 4 out of 5 stars

i would like this extension be compatible with firefox 3.5 ....il is possible ? is very useful cause i can see imagines and content covered by flash ....other extensions ..remove kil etc..flash are not very useful in this case.