Work fine Rated 4 out of 5 stars

However using notifications instead of changing extension icon is wrong. Look how YesScript does that for example.

Virtually not working anymore Rated 1 out of 5 stars

Regardless the issues I commented in my last review, I was quite happy with this add-on.
However, after installing the new browser upgrade, the icon for switching flash seems to be completely gone. It cannot be found anywhere (I tried Customize, not there either). And so, this add-on is render basically useless: you cannot switch flash without a button.
If the developer listened a bit to what people have to say and paid attention to details, this could be a great add-on. At the moment, it's simple -again- useless.

This user has a previous review of this add-on.

Crude Rated 2 out of 5 stars

Althought the functionality is great and highly needed...
- No customization options at all
- The flash icon in firefox status bar does not show if it is disabled or enabled (come on!)
- Clicking on the icon triggers a notification. This notification would be superfluous of the icon would change color depending on the state of flash. Clicking the icon 6 times in a row will generate 6 consecutive notifications (flash enabled,disabled,enabled,etc.). Since the Ubuntu default for the notification duration is 10 seconds, you will have useless notifications for 1 minute.

Rated 5 out of 5 stars

This is the best Flash disabler out there. BY FAR. This does what its supposed to do... DISABLE flash, not block the flash from playing. Perfect for web developers who want to test non Flash variables and content.

Does the Job Rated 4 out of 5 stars

I did write a review, but it appears blank after I submitted it :(

Could you make Flashtoggle available for toolbars too? I don't use the add-in bar.

I successfully moved the icon from the add-in bar to my navigation toolbar, but when I restart my browser it's back in the add-in bar :(

A whitelist would be a nice enhancement too :)

could be compatible with firefox 3.5 ? Rated 4 out of 5 stars

i would like this extension be compatible with firefox 3.5 ....il is possible ? is very useful cause i can see imagines and content covered by flash ....other extensions ..remove kil etc..flash are not very useful in this case.