Won't Install Rated 1 out of 5 stars

When I tried to install it, I got an error window saying it couldn't be installed, because "the file couldn't be modified". Now, what file is it talking about , and why can't it be installed? I'm running Firefox 5.0.1 on a Mac...

This review is for a previous version of the add-on (1.5.15.1).