Great! It needs updating but someone did already! Rated 4 out of 5 stars

Although this version is not FF 3.x enabled there is a modified version of this extension that is which is available from http://www33.websamba.com/sp88s5/fxlikeie.htm at the download page http://www33.websamba.com/sp88s5/firesomething.htm . The author states in a disclaimer that it is not his work and that he has only modified it to work on FF 3.x