Still working :) Rated 5 out of 5 stars

Recently switched to Ubuntu and using Firefox again. Luckily, my old favourite still works with Nightly Tester Tools addon (disable addon Compatibility Check). But I think you have to hit the Ctrl+` shortcut every time you start FF for it to change name.

Cheers from Armada Spacepelican ;)

Rated 5 out of 5 stars

Using the add-on compatibility reporter to check, as far as I can tell it still works with the latest version of firefox as of this comment.

Rated 5 out of 5 stars

One of the best add-ons, unfortunately discontinued :(

Rated 5 out of 5 stars

**clarification**
rename the "firesomthing.xpi" to "firesomething.zip"
before extracting, open the file and notice the directory structure within the archive.. extract (to a work folder) as any normal zip file would.
open the "install.rdf" in any text editor
change the
<em:maxversion> 2.0.0.* to something like4.0.*
save, add them all back to a zip file, keeping in mind the original directory structure, rename back to .xpi , drop on firefox, and you're done..
also, if you're tired of inputting all your words each time you reinstall, you can edit the "firesomething-defaults.js" found in the
"\defaults\preferences\" folder that was extracted, open it in any text editor, add your words on the same lines as the default words using the same format with a | between each word

Tried the hack from skittered Rated 3 out of 5 stars

It doesn't work on 3.5... the error message is:
Firefox could not install the file at
file:///C:/DATA/downloads/firesomething.xpi
because: Install script not found
-204

Any suggestions? Do I have to change the Install file somehow?

Thanks in advance.

Rated 5 out of 5 stars

I'm still using this with no problems in Firefox 3.0.13 by going to http://quitt.net/mozilla/extensions/ and downloading firesomething-1.8.0-fx-patched3.xpi near the bottom of the page. Thanks to previous commenter kdq for fixing it and making it available on his site. He has also fixed some other extensions like linkchecker which I also sorely missed.

Another option.. Rated 4 out of 5 stars

If anyone's looking for a similar addon like I was, the Nightly Tester Tools addon has similar functionality (although it doesn't let you have a randomly named Firefox).

inutile! Rated 1 out of 5 stars

Mah, per quanto mi riguarda è un'addon abbastanza inutile. Com'è descritto sopra l'addon non fa altro che cambiare il nome di firefox nella barra.
Veramente inutile.

Rated 5 out of 5 stars

It's just fun!

Please, Cosmic Cat, update this for Firefox 3.5+.

Rated 5 out of 5 stars

Please update this for ffx3. I have been using it for ages. Yes I know you can force it to work by editing the xpi but it would be great to see active development on this silly and fun add on.

Please Update For 3.0 and Abov!!!!! Rated 5 out of 5 stars

I used Firesomething before I updated to Firefox 3.0. And I loved it. It made things real interesting. And very funny. It was easy to use and install, and I had no problems with compatibility with other add-ons. If I can figure out how to down grade to Firefox 2 again, I would just so I can use this add-on (and a few others that I was using, that don't work now.). Thanks for a great add-on! But I'll say again...

Please Update It!!!!

modify firesomething Rated 5 out of 5 stars

as was said earlier
rename the 'firesomthing.xpi' to 'firesomething.zip'
extract to a folder as any normal zip file would
open the 'install.rdf' in any text editor
change the
2.0.0.*
to something like
4.0.0.*
save , add them all back to a zip file, change the .zip to .xpi , drop on firefox, and you're done..
also, if you're tired of inputting all your words each time you reinstall, you can edit the
"firesomething-defaults.js"
found in the
"\defaults\preferences" folder that was extracted,
open it in any text editor, add your words on the same lines as the default words using the same format with a | between each word, save when you're done

Wished for update Rated 4 out of 5 stars

I would be much more likely to add more work for my ancient XP pc to do if I could input my own names, such as 'Mainfox' 'ITfox' 'FinanceFox' (etc.) and be able to attach them to windows with related content open in them at my command, not randomly.

Updatee Rated 5 out of 5 stars

can u please update it to firefox 3

Rated 1 out of 5 stars

can you make the one for the newer firefox??

Rated 5 out of 5 stars

@ThomasKetner, blake93

Stop whining and fix it yourselves. It is really easy:
Download the add-on, rename it from .xpi to .zip and then change the file install.rdf inside the archive.
Somewhere you can find a line which says "maxversion". Just change the number thereafter and you're fine.
I just love what the add-on comes up with, 5 stars!

Rated 1 out of 5 stars

how do you make it work....?

Great! It needs updating but someone did already! Rated 4 out of 5 stars

Updated version available from http://www33.websamba.com/sp88s5/fxlikeie.htm at download page http://www33.websamba.com/sp88s5/firesomething.htm with disclaimer stating not original work and updated only to make it work with FF 3.x

Great! It needs updating but someone did already! Rated 4 out of 5 stars

Although this version is not FF 3.x enabled there is a modified version of this extension that is which is available from http://www33.websamba.com/sp88s5/fxlikeie.htm at the download page http://www33.websamba.com/sp88s5/firesomething.htm . The author states in a disclaimer that it is not his work and that he has only modified it to work on FF 3.x

Rated 3 out of 5 stars

make it work with 3.0