FF 6.0 Rated 4 out of 5 stars

It seems to work with FF 6.0, but its version info is not updated.

This review is for a previous version of the add-on (1.3.1-signed.1-signed).