latest version 0.98.9 is not functional with firefox 3.6 Rated 5 out of 5 stars

Version 0.98.9 does not work with firefox 3.6 at all.
Upon every use it gives a "Gecko 2" error.

Previous version i.e. 0.98.2 is working fine.
(addons.mozilla.org/de/firefox/addon/fireshot/versions/0.98.2)

This review is for a previous version of the add-on (0.98.9). 

Thanks for your rating despite on the problem. You can get the update here: http://screenshot-program.com/fireshot/amo.php