Rated 4 out of 5 stars

Great add-on, thanks!

Not functional w/ FF 3.6 yet. Has anyone confirmed compatibility by manually switched the version limit yet?

This review is for a previous version of the add-on (0.9.1).