Rated 5 out of 5 stars

I can't find your email contact so the bug report goes here. Firemacs 3.5 is incompatible with Firefox 3.5; hope to see an update soon, it's a fabulous addon!

This review is for a previous version of the add-on (3.5).