Rated 5 out of 5 stars

There is still No update for this add-on I sure which the Developer would get this fixed. it just seems that Firefox should make these updates happen faster!

Rated 1 out of 5 stars

Could you try to make it compatible with the newer versions of firefox?
I would love to download it, but it just isn't compatible.
Ill come back and give 5 stars when i can use it.

Hi everybody Rated 5 out of 5 stars

Rat la hay do,minh den tu viet nam

Slow update Rated 5 out of 5 stars

I love it but they are very SLOW with there updates
the last time they yp dated this was in may of 2007 & it's now 2009. sure wish that they could keep up!!!!!

FireHawke 3D Rated 5 out of 5 stars

This is a Assume Theme I just wish that it was out for FF3 or that it would keep up to date!!!

Rated 5 out of 5 stars

https://addons.mozilla.org/en-US/firefox/images/p/13308/1175791082

Rated 4 out of 5 stars

i like it but when is it for FF3?

Rated 5 out of 5 stars

einfaches, schönes kleines theme. sollte auch für FF3 erhältliche sein !

Я возмущена Rated 4 out of 5 stars

Ну почему все прикольные темы не доступны для третьей версии??????????????!!!!!! (((((((((((((

Rated 4 out of 5 stars

My only complaint would be that it is not available to FF3. Other than that it is one of my favorite themes for FF. Once it is available for FF3 it will get 5 stars.

Rated 5 out of 5 stars

nice one

Rated 1 out of 5 stars

Can't find Linux version :|

Rated 1 out of 5 stars

Can't find Linux version :|

Rated 3 out of 5 stars

Firefox 3.0.1

Rated 1 out of 5 stars

does not work with the current version of firefox (3.0.1).

3D? Rated 1 out of 5 stars

where is the 3D effect?
and NO i ve got
firefox 2.9
not 3

No funciona en la version 3.0 Rated 1 out of 5 stars

Por favor arreglen la compatibilidad de este complemento, gracias ;-)

wefwe Rated 2 out of 5 stars

qwedwed

Great Job Rated 5 out of 5 stars

Like the 3D experience of web browsing, makes you feel sooo techno. But it doesn't work with the new firefox 3

Rated 5 out of 5 stars

Can you pls make it compatible for firefox 3...