Firefinder doesn't work with Firefox 3.5.8 Rated 2 out of 5 stars

I downloaded Firefox latest Firefinder and tried working on that.. But it doesn't work. I am using Firefox 3.5.8

Pls help me regarding that..

Thanks,
Sairam.

This review is for a previous version of the add-on (1.1). 

You need to have the latest Firebug installed, since it's an extension for Firebug.