Rated 2 out of 5 stars

Not compatible with FF 3.5.2

This review is for a previous version of the add-on (0.9.1).