Does not work w/FF 3.6.17 Rated 1 out of 5 stars

I tried all the various versions on the author's site but none work with FF v3.6.17.