Rated 5 out of 5 stars

amazing and so useful .. But it's not compatible with Firefox 3.5 I'm force it to compatible with FF3.5 ..But it's Not Work Good :( .. Please Update to 3.5

This review is for a previous version of the add-on (1.0.2).