Rated 4 out of 5 stars

The new Firefox 4 beta won't let you install the extension. Follow these steps to get it to accept it:

1) Open about:config
2) Right-click and select New -> Boolean
3) Enter this name:
extensions.checkCompatibility.4.0b
4) Set it to false

The extension might still fail to work, but you can at least try it now.

This user has other reviews of this add-on.