not working with 3.6a1 Rated 3 out of 5 stars

I tried it with 3.6a1 and it doesn't seem to work. Trying to access the settings for the FTU causes the add-on manager to crash. And there is no FTU entry in the context menu.

Maybe this only happens because of the alpha status of 3.6

But does anyone know of another extension like FTU I could use for now?