Please! Rated 4 out of 5 stars

Two thing to comment:

1) Wi th Firefox 3.0 and Awareness API enabled, the extention doesn't recognize it and shows me the error message.

2) With the new version of Firefox, 3.5, your extention isn't compatible so PLEASE upgrade it :D