7.1.0 not working Rated 4 out of 5 stars

Up to this version FEBE has worked excellently. But sadly on this latest version it no longer backs up any of my extensions. Worse still, it will not even perform a basic backup.I'm going to try and downgrade and see if that fixes it.

Edit: Thanks Chuck. I thought I was up to date. But clearly not. Auto update doesn't find the new version btw. Many thanks for the reply. :)

This review is for a previous version of the add-on (7.1.0.1-signed). 

As mentioned in the "About this Add-on" section above, Firefox v20.0 needs FEBE v7.3.0 which is available from the FEBE homepage at http://softwarebychuck.com/febe/febe.html#latest.