FEBE Rated 1 out of 5 stars

Does not back up my ext on my firefox, useless, crap, sort it out or i am off

This review is for a previous version of the add-on (7.1.0.1-signed). 

As mentioned in the "About this Add-on" section above, Firefox v20.0 needs FEBE v7.3.0 which is available from the FEBE homepage at http://softwarebychuck.com/febe/febe.html#latest.