Rated 5 out of 5 stars

Do not bakcup from firefox version 20.
FEBE is unsupported?
Restore is working. bakcup only fail.
If you can, please support or how to work please tell me.

This review is for a previous version of the add-on (7.1.0.1-signed). 

Upgrade to FEBE 7.3

As mentioned in the "About this Add-on" section above, Firefox v20.0 needs FEBE v7.3 which is available from the FEBE homepage at http://softwarebychuck.com/febe/febe.html#latest.