Working in FF9 Rated 5 out of 5 stars

I'm not sure why it's not working for some. It's running great for me using the add-on Compatibility Reporting add-on in FF 9.0.1 on Windows 7 x64 (standard 32-bit FF install). Maybe try forcing compatibility with the add-on Compatibility Reporter extension? https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/?src=api. The only other thing I can figure, for those experiencing trouble, is that something else is conflicting with this extension or maybe those users have a different OS that brings about the problem.

This user has a previous review of this add-on.