Rated 5 out of 5 stars

Actually... you can adjust the RDF file for this add-on (in the Mozilla\Firefox\Profiles\[xxxx].default\extensions\facebookblocker@webgraph.com folder, use your text editor of choice to open "install.rdf"), by changing the line

em:maxVersion="4.*" />
to
em:maxVersion="7.*" />

(It's the second to last line in the file.)

Restart the browser to make the change take effect. Appears to be working again on my system. :-)