Compatible with FF4 Rated 4 out of 5 stars

This extension is fantastic to have. Can you please make it compatible with FF4?