You can use it on Firefox 5.01 with the "add-on compatiblity reporter" Rated 4 out of 5 stars

Works perfectly well with the help of the "Add-on Compatibility Reporter 0.8.7" on FF 5.O1
https://addons.mozilla.org/fr/firefox/addon/add-on-compatibility-reporter/?src=api