Rated 5 out of 5 stars

essential add-on!

works with FF 4.0, used Add-on Compatibility Reporter to install (and submit compatibility report).