Rated 1 out of 5 stars

I'm yet another that have been bugged by these script freezes.

XCM is claimed to be compatible with firefox 3.0b1 – 3.6.* but it is not!

And checking for plugin compatibility when upgrading firefox shows XCM to be compatible.

Have been using this addon previously with great success, but will never again use it.

I have spent to much time figuring out what caused the freezes, and also two chrashes, of firefox. It causes the browser to freeze, and also puts the PC to a sluggish halt at regular intervals.

This has cost me both time and money!

I certainly cannot recommend this addon.