Please support 3.1! Rated 3 out of 5 stars

3.1 support would be nice! :)

This review is for a previous version of the add-on (0.34). 

Support has been added.

Support has been added through Firefox 3.5.*. Thanks for your comments. :)