eQuake Alert! Version History

12 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 8.2.0 100.7 kB Works with Firefox 29.0 and later

Added:
  • Banner image for the About page.
  • Font-selector for a few fixed-width fonts to make the status-bar more readable.
  • Generic preferences handling functions and "automatic" preferences updates.

Changed:
  • Redesigned logo using scalable graphics, exported various sized raster PNGs.
  • Refactored code, especially preferences handling and date formatting.
  • Used a fixed-width font to clean up the status-bar display.
  • Updated the source to properly include the correct license blocks in all files.

Fixed:
  • Fixed time and date padding of single-digit days of month or AM/PM hours.

Known Issues:
  • Still XUL/Overlay based (support deprecated, obsoleted soon to be removed).
  • Not designed or tested for Android Firefox.
  • Tested and working in Ubuntu Linux, with a few UI glitches.
  • Not tested on MAX OS X, but it should work.
  • Code not fully modularized.
  • Tested and seems to work on Firefox 49.0a1 E10S with no changes.

Version 8.1.0 67.1 kB Works with Firefox 29.0 and later

This is a quick interim release, to restore functionality to the USGS feed processing, and to meet the AMO validation and review policies which have changed considerably since the previous version.

For testing, we bumped up the minimum version to 29.0, which was somewhat arbitrarily chosen. Version 29.0 was the infamous "Australis" UI update which removed the Add-on Bar, which this add-on still depends upon. The previous minVersion was listed as 3.5, although the add-on was found to not function correctly in that browser. Rather than downloading and testing and debugging and researching each interim release from 3.5 to 29.0 (on a very slow internet, and a very large time investment in coding, for very little benefit to current areas that need attention), we just decided to bump to 29.0. If earlier version support is desired, let us know. You should probably just upgrade as there were a lot of major security vulnerabilities in older browsers. But we perhaps we can spend some time to see what the actual lowest supported version is, with the least amount of changes.

That will be addressed in a later version, but for now, you need to install either The Addon Bar (Restored) or the Classic Theme Restorer. "The Addon Bar Restored" will restore the add-on bar and nothing else, where the "Classic Theme Restorer" add-on will change most of the Australis UI theme back to something similar to v28 and earlier, which also includes the add-on bar. So you do not need both.


The maxVersion tested was 49.0a1, so this should work for a few months at least, while we continue our development efforts! Overall, from 29.0a1 to 49.0 release, it will be nearly 3 years of browser versions supported.

One of the major noticeable changes is that the Geomap editor has been temporarily disabled and removed. This was absolutely necessary to comply with the new security and review policies and processes to get AMO to sign the add-on. It is more important to push out the updated USGS feed processing trather than cause any further delays as we redevelop that functionality. Please note however, that the Geographical Area can still be selected, and will still filter your results.

Also, all translations except for English have been temporarily removed. The automated AMO validation process revealed that many of the languages had incomplete translations. It will take time to review each of the languages, and resolve any problems. But we wanted to get this released as quickly as possible. Regardless, the upstream data was in English only, so this probably has minimal affect on users.

There is still occasionally some odd behavior with the geo and magnitude filtering. We are aware of this and continue efforts to fix this glitch.

Version 8.0.1.1-signed 119.7 kB Works with Firefox 0.3 and later

Uses the New USGS format
Precise Location information

Version 7.0.1.1-signed 126.0 kB Works with Firefox 3.5 and later

Compatible with Latest Firefox 3.5 through 9.0

Version 4.3.3.6 119.8 kB Works with Firefox 1.0 and later

Version 3.5.0 49.2 kB Works with Firefox 1.0 - 3.5.*

Please gimme feedback on this extension.

Next version will have filter by location & popin alert options(geo-map).

Now supports Firefox 3.5

Version 3.0.1 49.2 kB Works with Firefox 1.0 - 3.0.*

Now supports Firefox 3

Version 3.0.0 49.2 kB Works with Firefox 1.0 - 3.0b4pre

Added support for Firefox Beta 3

Version 2.1.2 49.2 kB Works with Firefox 1.0 - 2.0.0.*

1. Added option to show Status bar icon/message
2. Status bar message is now customizable
3. Fixed bugs in the shake
4. Added new menu items 'Your Quakes' (appears when you filter the quakes by magnitude) and 'Preview Shake'
5. Localized
Available in
af-ZA
bg-BG
en-US
es-AR
ml-IN
zh-CN
zh-TW

More on the way
fr-FR
it-IT
pl-PL
tr-TR
be-BY
es-ES
eu-ES
hr-HR
hi-IN
ms-MY
nl-NL
pt-BR
(Localizations made possible by Babelzilla.org. Those who wish to contibute may go here http://www.babelzilla.org/index.php?option=com_wts&Itemid=88&type=lang&extension=2774)

Version 2.1.1 49.2 kB Works with Firefox 1.0 - 2.0.0.*

1. Added option to show Status bar icon/message
2. Status bar message is now customizable
3. Intelligent shake code. Fixed bugs in the shake code (mostly when its minimized or in out of focus states)
4. Added new menu 'Your Quakes', which appears when you filter the quakes by magnitude
5. Localized
Available in
en-US
af-ZA
be-BY
bg-BG
es-AR
fr-FR
it-IT
ml-IN
pl-PL
tr-TR
zh-CN
zh-TW

More on the way
es-ES
eu-ES
hr-HR
hi-IN
ms-MY
nl-NL
pt-BR
(Localizations made possible by Babelzilla.org. Those who wish to contibute may go here http://www.babelzilla.org/index.php?option=com_wts&Itemid=88&type=lang&extension=2774)
6. Added a 'Preview Shake' option

Version 2.1 47.1 kB Works with Firefox 1.0 - 2.0.0.*

1. Added option to show icon instead of Status bar message
2. Status bar message is now customizable
3. Intelligent shake code. Fixed bugs in the shake code (mostly when its minimized or in out of focus states)
4. Added new menu 'Your Quakes', which appears when you filter the quakes by magnitude
5. Localized
Available in
en-US
af-ZA
be-BY
bg-BG
es-AR
fr-FR
it-IT
ml-IN
pl-PL
zh-TW

More on the way
es-ES
eu-ES
hr-HR
hi-IN
ms-MY
nl-NL
pt-BR
tr-TR
(Localizations made possible by Babelzilla.org. Those who wish to contibute may go here http://www.babelzilla.org/index.php?option=com_wts&Itemid=88&type=lang&extension=2774)
6. Added a 'Preview Shake' option

Version 2.0 9.2 kB Works with Firefox 1.0 - 2.0.0.*

Now works with Firefox 2