Rated 1 out of 5 stars

Doesn't work with FF5

This review is for a previous version of the add-on (1.1.1.1-signed).