Error Message Rated 5 out of 5 stars

Hi, I think this would be a good add-on, but when I installed it I couldn't use it, I get the message "requires additional items". But it doesn't say what. The Options and Enable tabs don't work, just the Uninstall tab. I'm using Firefox 3.5.3.
I'd really like the idea of this add-on

This review is for a previous version of the add-on (1.0.6).