Really good! Just make sure you have the newest version! Rated 5 out of 5 stars

2.5.1 stopped working with my version of Firefox, so I got 2.7. Always make sure you get the latest release from https://addons.mozilla.org/en-us/firefox/addon/elementary-firefox/versions or else you might not have optimal results.

This review is for a previous version of the add-on (2.5.1).