Looks like it would be very useful! Rated 4 out of 5 stars

Aargh. Doesn't work with FF5. (I use Debian.) I've gotten so tired of FF upgrades that ignore whether they'll work with your set of addons, that I had it pinned to version 4. But somehow the upgrade to 5 slipped past me, and now this. I *need* this. I am so-o-o tired of the squiddy little bookmark popup. Please get it to work with 5 asap! :D

(Rating doesn't apply in this case, but they force me to choose one.)

This review is for a previous version of the add-on (0.1.0.1-signed).