Rated 5 out of 5 stars

I don't have an option to upgrade to Firefox 3.6, but it works just fine with 3.5.5

This review is for a previous version of the add-on (1.4).