Can't install it Rated 1 out of 5 stars

Although the version information indicates it "Works with Firefox 18.0 and later " it will not install into Firefox 23.0.1. Therefore I can only give it one star.