Correct workaround for FF 3.6 Rated 4 out of 5 stars

for all people who want to make this work in FF 3.6, see my workaround below which works

don't bother trying to edit install.rdf, that won't work