Icon of Dynalinks

Dynalinks 1.0.6 Compatible with Firefox 57+

by Dark Energy

Dynalinks tab manager and thematic links catalog.

This add-on has been marked as experimental by its developers