Rated 5 out of 5 stars

I think it's great!

But what I really miss is support for 3.6 (or can I just modify the xpi file?)

This review is for a previous version of the add-on (2.2).