Rated 5 out of 5 stars

I wish this would be available for recent firefox...

Reply Rated 5 out of 5 stars

Thanks Rachel, can we do the same for version 3.6.6? What is the path to the "install.rdf" and to edit it do I just open it? Thanks!

Rated 5 out of 5 stars

Excellent app! Simple and easy to use. Still works in v3.6.3 - there doesn't seem to be anything incompatible here, just the developer did not edit the install.rdf file to keep up with new versions. To change the version number, see the instructions here: http://bit.ly/3JRv0N. I changed the version number to 99, to avoid future update issues.

BEST addon! Rated 5 out of 5 stars

Absolutely the best Tab addon I've ever used. Best because it adds a "duplicate tab" BUTTON to your firefox that you can then put where you want it (using customize)

It is certainly a shame that development of this addon has been discontinued, but I changed the .xpi file to work up till version 9.9 as described by others. Thanks!

Rated 4 out of 5 stars

Works fine in Firefox 3.6.3. if you change the version number in install.rdf.

Pity it's discontinued Rated 5 out of 5 stars

I loved this extn. I really only use Duplicate & Detach and this was just what I needed.
I haven't found another Extn Quote like this one.
Pity it is discontinued

XPI FF 3.6.3 Compatible Rated 4 out of 5 stars

The below link has an .xpi works on my FF 3.6.3

====================== =======================
Installed Firefox 3.5 but Duplicate tab isn’t working? | nickriebe.com
September 12, 2009
http://nickriebe.com/installing-to-firefox-3-5-but-duplicate-tab-isnt-working/

XPI FF 3.6.3 Compatible Rated 4 out of 5 stars

The below link has an .xpi works on my FF 3.6.3

====================== =======================
Installed Firefox 3.5 but Duplicate tab isn’t working? | nickriebe.com
September 12, 2009
http://nickriebe.com/installing-to-firefox-3-5-but-duplicate-tab-isnt-working/

Rated 3 out of 5 stars

please update your addon...

this is crazy, people not updating their addon developmental.
its killing users.....

Rated 3 out of 5 stars

Please update your addon

Rated 1 out of 5 stars

Please update this plugin.
Many users are currently using this plugin
and this plugin has not been updated since 2008.

Please update your plugin.

Rated 3 out of 5 stars

For updated Ffox versions: I am using Tabberwocky instead, which is great, duplicates tabs and has many other great features.

Update.... Rated 4 out of 5 stars

Please!!
Update for Firefox 3.6!!!

Firefox 3.6 Update Rated 5 out of 5 stars

http://rapidshare.com/files/362805150/duplicatetab-1.0.2.xpi.html

(Just 10 downloads allowed by RapidShare, please, upload it anywhere else).

Please update Rated 1 out of 5 stars

Please update for Seamonkey 2.0.3!

Rated 5 out of 5 stars

The Tab Control add-on once had this feature, but it was removed. And even though FF now has a native duplicate tab function, there's no easy-click context menu for it. A cumbersome keyboard+mouse dragging procedure is required. So, this extension is very useful. Thanks for providing it!

(What an ordeal to post this review... signed up and verified using Firefox, and then it wouldn't let me log in with Firefox no matter what I tried. Had to log in with Opera.)

Rated 5 out of 5 stars

The Tab Control add-on once had this feature, but it was removed. And even though FF now has a native duplicate tab function, there's no easy-click context menu for it. A cumbersome keyboard+mouse dragging procedure is required. So, this extension is very useful. Thanks for providing it!

(What an ordeal to post this review... signed up and verified using Firefox, and then it wouldn't let me log in with Firefox no matter what I tried. Had to log in with Opera.)

Rated 5 out of 5 stars

what i have NEVER understood... is WHY ISN'T hasn't this been made native???

* i can remember when fx needed extensions to drag tab order or undo tab closing... and those simple, yet convenient functions were eventually incorporated; because we users found them so handy... why hasn't tab dupeing by now?

bring this back ! Rated 5 out of 5 stars

I would definitely prefer this to FF3's way of ctrl + mouse to tab area which works like crap.

Gonna try to edit the rdf. Never understood why the heck extension developers limit their target versions like this when they dont even know what the changes will be in the next version and this involuntarily render itself useless.

Works with FF 3.6 Rated 5 out of 5 stars

V.1.0.2 works with FF 3.6 well after install.rdf´s is edited... Thanks!