Rated 5 out of 5 stars

I posted a working add-on for Firefox. (I modified the original, now accepts Firefox to v10.9)
(Tested successful in FF7.0.1 stable, FF8 beta 1, FF9 (aka Aurora) alfa 2, FF10 (aka Nightly) alfa 1) Only-32bits.

Hi Devilush, i like test the addon before recomend.
¿You tested this addon in Firefox 11, 12, 13..99?

By the way: DuplicateTab have minor issues with FF Nightly x64. (Can't change settings).

This user has 6 previous reviews of this add-on.