Rated 3 out of 5 stars

As said latest version 1.9.36 still doesn't work with FF 3.6

This review is for a previous version of the add-on (1.9.36).