Does not work in SeaMonkey 2.5 Rated 4 out of 5 stars

One of my half-dozen or so most indispensable add-ons. Unfortunately, while version 2.0.8 works in SeaMonkey 2.4, it fails in SeaMonkey 2.5.

Changing the maxVersion value in the install.rdf file to 2.5 produces an error message "The add-on downloaded from unknown host could not be installed because it appears to be corrupt."

Please update soon to enable this otherwise marvelous add-on to work properly in SeaMonkey 2.5.

This review is for a previous version of the add-on (2.0.8).