Rated 5 out of 5 stars

Doesn't work with FF8, which didn't list it as incompatible and didn't even invite me to say "no" to upgrade. Is still on the add-ons list as enabled but there's no plugins in the settings dialogue and I can't reinstall it. I can't roll back to FF7, either. Please fix ASAP as this is a great utility and I use it daily - also would be nice to have a plugin included for ImageTwist and ImageChilli (I'm not savvy enough to write my own, sadly).

This review is for a previous version of the add-on (1.1).