Firefox 57 Support Rated 5 out of 5 stars

Hi,

This is a great extension, but we need it to support Firefox 57! Please bring it back!